package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^FIXTEST_([A-Za-z0-9]+)\s+([0-9]+)\/tcp\s+#\s*([A-Za-z0-9.]+):([0-9]+)\s*`)
var str = `FIXTEST_XYZ 23040/tcp # 127.0.0.1:23040`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}