re = /^FIXTEST_([A-Za-z0-9]+)\s+([0-9]+)\/tcp\s+#\s*([A-Za-z0-9.]+):([0-9]+)\s*/
str = 'FIXTEST_XYZ 23040/tcp # 127.0.0.1:23040'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end