using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+,|[a-z]+)\d+|(\d+[.\d]*)";
string input = @" li 12.12 si 43,23 45 31 uf 889 uf31 3.12345";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}