// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\d+,|[a-z]+)\d+|(\d+[.\d]*)").unwrap();
let string = " li 12.12 si 43,23 45 31 uf 889 uf31 3.12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}