re = /(?:\d+,|[a-z]+)\d+|(\d+[.\d]*)/
str = ' li 12.12 si 43,23 45 31 uf 889 uf31 3.12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end