$re = '/(?:\d+,|[a-z]+)\d+|(\d+[.\d]*)/';
$str = ' li 12.12 si 43,23 45 31 uf 889 uf31 3.12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);