package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]{3,6}@fightclub\.(?:uk|lk|sa|cc|jp|se|xy|gi|rl|ss)$`)
var str = `abc@fightclub.uk
abc343@fightclub.lk
abcdefsdf@fightclub.sa
am@fightclub2.lk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}