$re = '/^[a-z0-9]{3,6}@fightclub\.(?:uk|lk|sa|cc|jp|se|xy|gi|rl|ss)$/m';
$str = 'abc@fightclub.uk
abc343@fightclub.lk
abcdefsdf@fightclub.sa
am@fightclub2.lk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);