import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{3,6}@fightclub\\.(?:uk|lk|sa|cc|jp|se|xy|gi|rl|ss)$";
final String string = "abc@fightclub.uk\n"
+ "abc343@fightclub.lk\n"
+ "abcdefsdf@fightclub.sa\n"
+ "am@fightclub2.lk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}