const regex = /^[a-z0-9]{3,6}@fightclub\.(?:uk|lk|sa|cc|jp|se|xy|gi|rl|ss)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]{3,6}@fightclub\\.(?:uk|lk|sa|cc|jp|se|xy|gi|rl|ss)$', 'gm')
const str = `abc@fightclub.uk
abc343@fightclub.lk
abcdefsdf@fightclub.sa
am@fightclub2.lk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}