using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^\)\)]*?\)(?!.\()";
string input = @"Klacid Filmtabl 500 mg (Clarithromycin)
Co-Amoxi Mepha Trockensub 1'200 mg (1.2 g) (Amoxicillin, Clavulansäure)
Benerva Tabl 300 mg (Thiamin (Vitamin B1))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}