$re = '/\([^\)\)]*?\)(?!.\()/';
$str = 'Klacid Filmtabl 500 mg (Clarithromycin)
Co-Amoxi Mepha Trockensub 1\'200 mg (1.2 g) (Amoxicillin, Clavulansäure)
Benerva Tabl 300 mg (Thiamin (Vitamin B1))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);