import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^\\)\\)]*?\\)(?!.\\()";
final String string = "Klacid Filmtabl 500 mg (Clarithromycin)\n"
+ "Co-Amoxi Mepha Trockensub 1'200 mg (1.2 g) (Amoxicillin, Clavulansäure)\n"
+ "Benerva Tabl 300 mg (Thiamin (Vitamin B1))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}