re = /\([^\)\)]*?\)(?!.\()/
str = 'Klacid Filmtabl 500 mg (Clarithromycin)
Co-Amoxi Mepha Trockensub 1\'200 mg (1.2 g) (Amoxicillin, Clavulansäure)
Benerva Tabl 300 mg (Thiamin (Vitamin B1))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end