#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!(\.cf|\.ga|\.gq|\.ml|\.tk)$).)*$"
Local $sString = "example.cf" & @CRLF & _
"example.ga" & @CRLF & _
"example.gq" & @CRLF & _
"example.ml" & @CRLF & _
"example.tk" & @CRLF & _
"example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")