import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!(\\.cf|\\.ga|\\.gq|\\.ml|\\.tk)$).)*$";
final String string = "example.cf\n"
+ "example.ga\n"
+ "example.gq\n"
+ "example.ml\n"
+ "example.tk\n"
+ "example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}