$re = '/^((?!(\.cf|\.ga|\.gq|\.ml|\.tk)$).)*$/m';
$str = 'example.cf
example.ga
example.gq
example.ml
example.tk
example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);