re = /^((?!(\.cf|\.ga|\.gq|\.ml|\.tk)$).)*$/m
str = 'example.cf
example.ga
example.gq
example.ml
example.tk
example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end