package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-fA-F0-9]{24}$`)
var str = `617c4d302bdaae79da0a6778`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}