$re = '/^[a-fA-F0-9]{24}$/';
$str = '617c4d302bdaae79da0a6778';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);