const regex = /^[a-fA-F0-9]{24}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-fA-F0-9]{24}$', '')
const str = `617c4d302bdaae79da0a6778`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}