using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s+[^\s]*\s+\d.*?Datum:\s*([\d\.]+)";
string input = @"Max Muster Musterstraße 22B 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Firma Musterhausen Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Sonja Musterfrau-Doppelhans Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Peter Muster-Whatever-Blablub Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}