import Foundation
let pattern = #"^(.*?)\s+[^\s]*\s+\d.*?Datum:\s*([\d\.]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Max Muster Musterstraße 22B 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Firma Musterhausen Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Sonja Musterfrau-Doppelhans Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Peter Muster-Whatever-Blablub Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)