use strict;
my $str = 'Max Muster Musterstraße 22B 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Firma Musterhausen Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Sonja Musterfrau-Doppelhans Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Peter Muster-Whatever-Blablub Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021';
my $regex = qr/^(.*?)\s+[^\s]*\s+\d.*?Datum:\s*([\d\.]+)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}