$re = '/^(.*?)\s+[^\s]*\s+\d.*?Datum:\s*([\d\.]+)/im';
$str = 'Max Muster Musterstraße 22B 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Firma Musterhausen Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Sonja Musterfrau-Doppelhans Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021
Peter Muster-Whatever-Blablub Musterallee 1a 11111 Musterhausen Fon: 04321 / 123456 Fax: 04321 / 23356 vertrieb@muster-text.de www.muster-text.de Kunden-Nr.: 023456 USt-IdNr.: DE111111111 Bestell-Nr.: 343213 Datum: 13.12.2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);