#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/\*<<@\*\/)((?:[^\/]|\/(?!\*))+?)(\/\*)((?:[^*]|\*(?!\/))+?)(\*\/)"
Local $sString = "/*<<@*/ '2018-07-20 00:00:00' /*My Date>>*/" & @CRLF & _
"/*<<@*/ 'whatever?' /*My String>>*/" & @CRLF & _
"/*<<@*/ 1 /*My Bool>>*/" & @CRLF & _
"" & @CRLF & _
"/*<<@*/whate/er*/a*/*aoe*u*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")