using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*<<@\*\/)((?:[^\/]|\/(?!\*))+?)(\/\*)((?:[^*]|\*(?!\/))+?)(\*\/)";
string input = @"/*<<@*/ '2018-07-20 00:00:00' /*My Date>>*/
/*<<@*/ 'whatever?' /*My String>>*/
/*<<@*/ 1 /*My Bool>>*/
/*<<@*/whate/er*/a*/*aoe*u*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}