re = /(\/\*<<@\*\/)((?:[^\/]|\/(?!\*))+?)(\/\*)((?:[^*]|\*(?!\/))+?)(\*\/)/m
str = '/*<<@*/ \'2018-07-20 00:00:00\' /*My Date>>*/
/*<<@*/ \'whatever?\' /*My String>>*/
/*<<@*/ 1 /*My Bool>>*/
/*<<@*/whate/er*/a*/*aoe*u*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end