import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*\\*\\n(.*?)\\*/\\n(?=#cmakedefine (\\w+))";
final String string = "/**\n"
+ " * 1st Multi-line brief description of what the following \n"
+ " * cmakedefine does.\n"
+ " *\n"
+ " * Second more complicated multi-line full description of , <c>SOMETHING</c> to be enabled in the\n"
+ " * configuration.\n"
+ " *\n"
+ " * Possibly additional lines of full description.\n"
+ " */\n"
+ "#cmakedefine SOMETHING\n"
+ "/**\n"
+ " * Brief description\n"
+ " *\n"
+ " * Long Description\n"
+ " */\n"
+ "#cmakedefine SOMETHING_ELSE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}