$re = '//\*\*\n(.*?)\*/\n(?=#cmakedefine (\w+))/ms';
$str = '/**
* 1st Multi-line brief description of what the following
* cmakedefine does.
*
* Second more complicated multi-line full description of , <c>SOMETHING</c> to be enabled in the
* configuration.
*
* Possibly additional lines of full description.
*/
#cmakedefine SOMETHING
/**
* Brief description
*
* Long Description
*/
#cmakedefine SOMETHING_ELSE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);