const regex = new RegExp('/\\*\\*\\n(.*?)\\*/\\n(?=#cmakedefine (\\w+))', 'gms')
const str = `/**
* 1st Multi-line brief description of what the following
* cmakedefine does.
*
* Second more complicated multi-line full description of , <c>SOMETHING</c> to be enabled in the
* configuration.
*
* Possibly additional lines of full description.
*/
#cmakedefine SOMETHING
/**
* Brief description
*
* Long Description
*/
#cmakedefine SOMETHING_ELSE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}