# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/\*\*\n(.*?)\*/\n(?=#cmakedefine (\w+))"
test_str = ("/**\n"
" * 1st Multi-line brief description of what the following \n"
" * cmakedefine does.\n"
" *\n"
" * Second more complicated multi-line full description of , <c>SOMETHING</c> to be enabled in the\n"
" * configuration.\n"
" *\n"
" * Possibly additional lines of full description.\n"
" */\n"
"#cmakedefine SOMETHING\n"
"/**\n"
" * Brief description\n"
" *\n"
" * Long Description\n"
" */\n"
"#cmakedefine SOMETHING_ELSE")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.