const regex = /(.*inSlope: .\n)(.*outSlope: .\n)(?=(.|\n)*attribute: m_IsActive)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*inSlope: .\\n)(.*outSlope: .\\n)(?=(.|\\n)*attribute: m_IsActive)', 'gm')
const str = `- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 0
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_IsActive
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 5
inSlope: 0
outSlope: 0
tangentMode: 0
- serializedVersion: 3
value: 1
inSlope: 0
outSlope: 0
tangentMode: 0
- serializedVersion: 3
value: 5
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_Frame
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 1
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_IsActive`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}