import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(.*inSlope: .\n)(.*outSlope: .\n)(?=(.|\n)*attribute: m_IsActive)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 0
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_IsActive
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 5
inSlope: 0
outSlope: 0
tangentMode: 0
- serializedVersion: 3
value: 1
inSlope: 0
outSlope: 0
tangentMode: 0
- serializedVersion: 3
value: 5
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_Frame
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 1
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_IsActive
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)