# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*inSlope: .\n)(.*outSlope: .\n)(?=(.|\n)*attribute: m_IsActive)"
test_str = ("- curve:\n"
" serializedVersion: 2\n"
" m_Curve:\n"
" - serializedVersion: 3\n"
" value: 0\n"
" inSlope: 0\n"
" outSlope: 0\n"
" tangentMode: 0\n"
" m_RotationOrder: 4\n"
" attribute: m_IsActive\n"
"- curve:\n"
" serializedVersion: 2\n"
" m_Curve:\n"
" - serializedVersion: 3\n"
" value: 5\n"
" inSlope: 0\n"
" outSlope: 0\n"
" tangentMode: 0\n"
" - serializedVersion: 3\n"
" value: 1\n"
" inSlope: 0\n"
" outSlope: 0\n"
" tangentMode: 0\n"
" - serializedVersion: 3\n"
" value: 5\n"
" inSlope: 0\n"
" outSlope: 0\n"
" tangentMode: 0\n"
" m_RotationOrder: 4\n"
" attribute: m_Frame\n"
"- curve:\n"
" serializedVersion: 2\n"
" m_Curve:\n"
" - serializedVersion: 3\n"
" value: 1\n"
" inSlope: 0\n"
" outSlope: 0\n"
" tangentMode: 0\n"
" m_RotationOrder: 4\n"
" attribute: m_IsActive")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.