$re = '/(.*inSlope: .\n)(.*outSlope: .\n)(?=(.|\n)*attribute: m_IsActive)/mU';
$str = '- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 0
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_IsActive
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 5
inSlope: 0
outSlope: 0
tangentMode: 0
- serializedVersion: 3
value: 1
inSlope: 0
outSlope: 0
tangentMode: 0
- serializedVersion: 3
value: 5
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_Frame
- curve:
serializedVersion: 2
m_Curve:
- serializedVersion: 3
value: 1
inSlope: 0
outSlope: 0
tangentMode: 0
m_RotationOrder: 4
attribute: m_IsActive';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);