#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?://(www.)?[A-z0-9]+\.[A-z0-9]+$"
Local $sString = "emreyl.yldrm@yandex.com" & @CRLF & _
"emMMreylyl-yl@gmail.com" & @CRLF & _
"emMMreylyl-yl@gmail.com" & @CRLF & _
"-emreyl.yldrm@yandex.com" & @CRLF & _
"9emreyl.yldrm@yandex.com" & @CRLF & _
"" & @CRLF & _
"https://regex101.com/r/IljuUr/" & @CRLF & _
"https://www.youtube.com" & @CRLF & _
"http://arin.com" & @CRLF & _
"https://stackoverflow.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")