package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?://(www.)?[A-z0-9]+\.[A-z0-9]+$`)
var str = `emreyl.yldrm@yandex.com
emMMreylyl-yl@gmail.com
emMMreylyl-yl@gmail.com
-emreyl.yldrm@yandex.com
9emreyl.yldrm@yandex.com
https://regex101.com/r/IljuUr/
https://www.youtube.com
http://arin.com
https://stackoverflow.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}