use strict;
my $str = 'emreyl.yldrm@yandex.com
emMMreylyl-yl@gmail.com
emMMreylyl-yl@gmail.com
-emreyl.yldrm@yandex.com
9emreyl.yldrm@yandex.com
https://regex101.com/r/IljuUr/
https://www.youtube.com
http://arin.com
https://stackoverflow.com';
my $regex = qr/^https?://(www.)?[A-z0-9]+\.[A-z0-9]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}