// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?://(www.)?[A-z0-9]+\.[A-z0-9]+$").unwrap();
let string = "emreyl.yldrm@yandex.com
emMMreylyl-yl@gmail.com
emMMreylyl-yl@gmail.com
-emreyl.yldrm@yandex.com
9emreyl.yldrm@yandex.com
https://regex101.com/r/IljuUr/
https://www.youtube.com
http://arin.com
https://stackoverflow.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}