using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.hb-fill-top(?::.*)?";
string input = @".hb-fill-top::before
.hb-fill-top:hover::before
.hb-fill-top
.hb-fill-top:hover";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}