import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.hb-fill-top(?::.*)?";
final String string = ".hb-fill-top::before\n"
+ ".hb-fill-top:hover::before\n"
+ ".hb-fill-top\n"
+ ".hb-fill-top:hover";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}