package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.hb-fill-top(?::.*)?`)
var str = `.hb-fill-top::before
.hb-fill-top:hover::before
.hb-fill-top
.hb-fill-top:hover`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}