import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\\\"result-title hdrlnk\\\">(.*?)<\\/a><span class=\\\"result-meta\\\"><span class=\\\"result-price\\\">(.*?)<\\/span>";
final String string = "class=\"result-title hdrlnk\">CHAVY IMPALA</a><span class=\"result-meta\"><span class=\"result-price\">$1300</span>\n\n"
+ "class=\"result-title hdrlnk\">1950 Buick Super straight 8 with 3 on the tree</a><span class=\"result-meta\"><span class=\"result-price\">$9850</span>\n\n"
+ "class=\"result-title hdrlnk\">Buick Lesabre Hardtop Coupe</a><span class=\"result-meta\"><span class=\"result-price\">$8800</span>";
final String subst = "TITLE: \\1\\nPRICE: \\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}