import Foundation
let pattern = #"class=\"result-title hdrlnk\">(.*?)<\/a><span class=\"result-meta\"><span class=\"result-price\">(.*?)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
class="result-title hdrlnk">CHAVY IMPALA</a><span class="result-meta"><span class="result-price">$1300</span>
class="result-title hdrlnk">1950 Buick Super straight 8 with 3 on the tree</a><span class="result-meta"><span class="result-price">$9850</span>
class="result-title hdrlnk">Buick Lesabre Hardtop Coupe</a><span class="result-meta"><span class="result-price">$8800</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"TITLE: \1\nPRICE: \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)