// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"class=\"result-title hdrlnk\">(.*?)<\/a><span class=\"result-meta\"><span class=\"result-price\">(.*?)<\/span>"#).unwrap();
let string = "class=\"result-title hdrlnk\">CHAVY IMPALA</a><span class=\"result-meta\"><span class=\"result-price\">$1300</span>
class=\"result-title hdrlnk\">1950 Buick Super straight 8 with 3 on the tree</a><span class=\"result-meta\"><span class=\"result-price\">$9850</span>
class=\"result-title hdrlnk\">Buick Lesabre Hardtop Coupe</a><span class=\"result-meta\"><span class=\"result-price\">$8800</span>";
let substitution = "TITLE: \\1\\nPRICE: \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}