use strict;
my $str = 'class="result-title hdrlnk">CHAVY IMPALA</a><span class="result-meta"><span class="result-price">$1300</span>
class="result-title hdrlnk">1950 Buick Super straight 8 with 3 on the tree</a><span class="result-meta"><span class="result-price">$9850</span>
class="result-title hdrlnk">Buick Lesabre Hardtop Coupe</a><span class="result-meta"><span class="result-price">$8800</span>';
my $regex = qr/class=\"result-title hdrlnk\">(.*?)<\/a><span class=\"result-meta\"><span class=\"result-price\">(.*?)<\/span>/p;
my $subst = 'TITLE: \\1\\nPRICE: \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";