using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*[\d$&+,:;=?@#|'<>.^*()%!-].*[\d$&+,:;=?@#|'<>.^*()%!-].*$";
string input = @"1sfdfsd2
asd12
3asd@df
22
@^
2*
*sff)f
.(()2fd
d1cdddd
@
aa@
@aaaa
xrg@aaaa
xrg4aaaa
xrg4aaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}