re = /^.*[\d$&+,:;=?@#|'<>.^*()%!-].*[\d$&+,:;=?@#|'<>.^*()%!-].*$/m
str = '1sfdfsd2
asd12
3asd@df
22
@^
2*
*sff)f
.(()2fd
d1cdddd
@
aa@
@aaaa
xrg@aaaa
xrg4aaaa
xrg4aaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end