package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[\d$&+,:;=?@#|'<>.^*()%!-].*[\d$&+,:;=?@#|'<>.^*()%!-].*$`)
var str = `1sfdfsd2
asd12
3asd@df
22
@^
2*
*sff)f
.(()2fd
d1cdddd
@
aa@
@aaaa
xrg@aaaa
xrg4aaaa
xrg4aaaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}